Welcome guest, is this your first visit? Create Account now to join.

Welcome to the Motorcycle Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22
  1. #1
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34

    My 50 won't start!

    Hello every one! I'm new on the forum...
    I have a '05 50 (changed from a Harley Xl 883) since 3yrs now. I always make the maintenance. She have been riding smoothly every day since 2007, until yesterday. When try to start it turns on the Fi light and the oil icon appears on the LCD screen. I checked the oil level and is ok (also is been only 1,600 miles from the last change). I debaffled her almost 2yrs ago. Anyone have any idea what could be happening to my little baby?

  2. MotorcycleForums.net is the original Motorcycle Forum! Registered Users do not see these ads. Please Register - It's Free!

  3. #2
    M-J Lifetime Achievement Award
    My Bike(s)
    '10 Kaw Vulcan 900 Custom
    Location
    Ocala, FL
    Posts
    8,615
    Quote Originally Posted by a1000k View Post
    When try to start it turns on the Fi light and the oil icon appears on the LCD screen.
    Welcome to the forum.

    First, I suggest you search the forum, maybe using the keyword "start".

    There are TONS of threads here already, that probably covers every possible cause of a bike not starting. One of them probably applies to you.

    If that doesn't do the trick, you are going to have to give us some more details about what happens when you turn the key to "start". If it just makes a click or the engine turns over REAL slow or not at all, it's the battery.
    Bad batteries are the most common cause; their expected life is somewhere between 3 to 7 years.

  4. #3
    Puddle Runner
    My Bike(s)
    2006 M50
    Location
    Alberta, Canada
    Posts
    357
    Does it turn over?

    Troubleshooting takes very different paths depending on if the starter operates or not.

  5. #4
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34
    Thanks for the replies...

    Actually I've been searching in the forum... When turn start it makes the usual Fi noise, but the engine wont'start... At the time when the Fi sounds comes, the Fi light keeps on and then on the lcd display appears the word CHECk and the oil can symbol. I guess is not the battery because all lights can turn on and the horns sounds... But I can get the battery check today... .

    Any other ideas?

  6. #5
    Fourth gear and illegal
    My Bike(s)
    2008 Suzuki DL1000
    Location
    North Coast of Ohio
    Posts
    711
    You say the motor won't start. Is it turning over but not firing?

  7. #6
    Leg Humps The Snap On Tool Man
    My Bike(s)
    Suzuki M50 VZ800/Z
    Location
    Aspen Co.
    Posts
    1,477
    You may need to make a visit to the dealer to have it scanned for codes. Your M is in fault mode and won't start because the compute has determined it may damage the engine to do so.
    Your lights and horn can work on a low battery when it won't crank. But they should be dim and sound weak. Throw a DVOM or voltage meter at the battery and see if it less than 12.3, anything lower and you may have a low battery.
    You may also have electrical gremlins- corrosion or poor connections preventing electricity to flow, a bad start button or a dead relay. How do the battery connections look? Are they loose? Start chasing voltage. If everything checks out Have it scanned. Also check to start in neutral and with the kick stand up, let's rule out the simple items first.
    NMc
    Profesional technition, auto, small engine and heavy diesel with five years paid experience and many more as a hobbyist.

  8. #7
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34
    Thanks,
    I'll check for voltage and any loose terminal as soon as I get home... I already tried to start on N and no kick stand...

    I'm hoping to be just a battery problem, 'cause dealer service is quite far from home, and have to get towed ($$$) to get there.

  9. #8
    Wants Better Weather
    My Bike(s)
    2008 Yamaha Roadliner
    Location
    Buffalo, NY
    Posts
    674
    You also might want to check the clutch switch on the handlebar. Those have been known to get dirt/grime in them and fail.
    TJ

  10. #9
    M-J Lifetime Achievement Award
    My Bike(s)
    '10 Kaw Vulcan 900 Custom
    Location
    Ocala, FL
    Posts
    8,615
    Quote Originally Posted by a1000k View Post
    Thanks,
    I'll check for voltage and any loose terminal as soon as I get home...
    You still haven't told us if the engine is turning over when you turn the key to START yet or not.

    The answers you are getting assume that it is NOT making the engine (or starter) run. If it IS turning the engine but still not starting, the suggestions would be somewhat different.

    Either way, once you have pretty much ruled out a bad battery and loose connections......with a FI engine, you pretty much have to get it to a dealer.

  11. #10
    Newbie
    My Bike(s)
    08 M50
    Location
    Syracuse, NY
    Posts
    15
    Killswitck on the right side of the handlebars??

  12. #11
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34
    When turned the key, the only thing that happens is the sound of the Fi (as usual) and then the Fi light and check message... Nothing else, the engine doesn't start nor choke either...

  13. #12
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34
    Quote Originally Posted by retsuhs View Post
    Killswitck on the right side of the handlebars??
    What's the Killswitck?

  14. #13
    Clunked into first gear
    My Bike(s)
    2005 Suzuki Boulevard M50 Black
    Location
    Lafayette, IN
    Posts
    231
    Quote Originally Posted by a1000k View Post
    What's the Killswitck?
    He meant kill switch, and it is the red switch that ur right thumb can hit. When the bike is running you switch it to turn it off. However, you need to switch it back to start it.
    '05 M50 Black

    Mods/Accessories: Debadged, Debaffled, Kury Iso Grips, Deballed Levers, Aftermarket Front/Rear Turn Signals and Mirrors, Cooley's Chin Spoiler

    Coming sooner or later: Cooley's 2 inch fluted risers, Flat black all over possibly with carbon fiber accents.

  15. #14
    M-J Lifetime Achievement Award
    My Bike(s)
    '10 Kaw Vulcan 900 Custom
    Location
    Ocala, FL
    Posts
    8,615
    Quote Originally Posted by a1000k View Post
    When turned the key, the only thing that happens is the sound of the Fi (as usual) and then the Fi light and check message... Nothing else, the engine doesn't start nor choke either...
    How about the headlight ? Is it on bright or dim ?

    It could be the battery or a bad connection........or the fuel pump or the fuel injection computer or the starter or any one of about 4 safety interlocks.

    I think it is going to have to visit the shop.

  16. #15
    Where Am I ?
    My Bike(s)
    M50 '05
    Location
    San Juan, Puerto Rico
    Posts
    34
    Ohh.. thanks for clarify. So the idea is that maybe the on switch is dead?


 

Ads

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. no start help PLEASE
    By ffron69 in forum V-Star ship the enterprise
    Replies: 5
    Last Post: 12-15-2009, 01:38 AM
  2. adjust clitch now won't start start
    By mmccord2@cox.net in forum Mechanics Corner
    Replies: 4
    Last Post: 06-20-2008, 08:10 PM
  3. Does your Kat start right away?
    By KATManDu in forum Katana Planet Emergency Shelter
    Replies: 24
    Last Post: 01-09-2008, 11:17 PM
  4. 01 Kat won't Start
    By Francais in forum Katana Planet Emergency Shelter
    Replies: 4
    Last Post: 07-10-2007, 09:56 AM
  5. cold start = no start ?
    By boz in forum Cruisers
    Replies: 29
    Last Post: 01-31-2005, 09:02 PM

Search tags for this page

2008 kfx 50 won't start
,
kawasaki kfx 50 won't start
,

kfx 50 wont start

,
m109r kill switch location
,

suzuki boulevard m50 wont start

,
suzuki boulevard won't start
,

suzuki boulevard wont start

,
suzuki m50 engine won't turnover
,
suzuki m50 wont start just clicks
,
trouble shooting kfx 50 wont start
Click on a term to search for related topics.