Turn signal problem when forks are turned
Welcome guest, is this your first visit? Create Account now to join.

Welcome to the Motorcycle Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Results 1 to 8 of 8
  1. #1
    Newbie
    My Bike(s)
    2006 Suzuki S50 Boulevard
    Posts
    3

    Turn signal problem when forks are turned

    2006 S50 - when the front forks are turned left the right front turn signal works. When the forks are turned right the right front turn signal will NOT blink. Any ideas?

  2. Remove Advertisements
    MotorcycleForums.net
    Advertisements
     

  3. #2
    Can Ride And Chew Gum
    My Bike(s)
    '08 Suzuki M50,1975 Goldwing,1982 Silverwing
    Location
    Hensley, Arkansas
    Posts
    2,015
    to the forums from Arkansas. One of the wires going to the right signal is open and makes contact when you move the forks.
    If you can't dazzle 'em with brilliance,Baffle 'em with Bulls!!t!

    Roadburner Street Pro's on my M http://www.youtube.com/watch?v=Hf0IYPcoiVc

  4. #3
    Seat Tester
    Posts
    95
    Put K+N air filter you won't regret it. Auto Zone just as cheap as Denniskirk

    tarheel

  5. Remove Advertisements
    MotorcycleForums.net
    Advertisements
     

  6. #4
    Still crazy after all these years

    My Bike(s)
    Blue Suzuki GSX 1400 (2003)
    Location
    Schliengen, Germany (47.754543, 7.631989)
    Posts
    14,176
    And if you think that replacing the air filter is going to fix an electrical problem, don't forget to replace your blinker fluid - it will add 25 horsepower to your engine performance. As long as you remember to lube the exhaust pipes and wash out the gas tank with distilled water before each filling. Sheesh.

    There is nothing worse than aggressive stupidity. - Johann Wolfgang von Goethe
    Pizza is not safe around me. - Me


  7. #5
    Super Moderator

    My Bike(s)
    Can-AM Spyder
    Location
    Ocala, FL
    Posts
    12,051
    Quote Originally Posted by Fitzall View Post
    Put K+N air filter you won't regret it. Auto Zone just as cheap as Denniskirk

    tarheel
    This makes no sense at all.
    Has nothing to do with turn signals.
    And on an S50 that runs lean to start with, you might indeed regret it.

    Explain a bit more, please.
    Don't believe everything that you think.

  8. #6
    Seat Tester
    Posts
    95
    You right that tex off the wall, shynot happens. What I should have said was that the pinch point is probably around the neck and don't discount looking inside the headlight housing. Mine was '02 Volusia 800 with carb.

    Sent from my Z797C using Tapatalk

  9. #7
    Newbie
    My Bike(s)
    2006 Suzuki S50 Boulevard
    Posts
    3
    Quote Originally Posted by AloRaptor View Post
    to the forums from Arkansas. One of the wires going to the right signal is open and makes contact when you move the forks.
    I have traced the problem to where the wires go into the "console" unit (where the indicator lights are). When I push on these wires the blinker will work. To open the back of this console unit looks like the entire headlight assembly has to be removed. I attached a picture where wires are entering unit. I used a pointer to show area. Does the headlight assembly have to be removed as it appears? Does anyone have instructions on how to remove it? Or a place I can find instructions?
    Attached Thumbnails Attached Thumbnails Turn signal problem when forks are turned-image.jpeg  

  10. #8
    Newbie
    My Bike(s)
    2006 Suzuki S50 Boulevard
    Posts
    3
    Quote Originally Posted by Kwp0928 View Post
    I have traced the problem to where the wires go into the "console" unit (where the indicator lights are). When I push on these wires the blinker will work. To open the back of this console unit looks like the entire headlight assembly has to be removed. I attached a picture where wires are entering unit. I used a pointer to show area. Does the headlight assembly have to be removed as it appears? Does anyone have instructions on how to remove it? Or a place I can find instructions?
    I found the way to get the light assembly off. Removed back of console unit. Looks like the loose connection may be in speedometer unit now. Slowly trying to get to the real problem. Now have to discover how to remove speedo cover to get to wires in the back of it.


 

Sponsored Links

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Turn Signal Problem HELP PLEASE
    By steel119 in forum Mechanics Corner
    Replies: 1
    Last Post: 05-06-2011, 03:55 AM
  2. Turn Signal Problem
    By cmacjvan in forum Marauder M50 Secret Hideaway
    Replies: 3
    Last Post: 05-01-2010, 11:45 PM
  3. turn signal problem
    By fredog in forum Mechanics Corner
    Replies: 6
    Last Post: 11-12-2009, 04:42 PM
  4. Turn signal problem?
    By tallannie in forum Mechanics Corner
    Replies: 6
    Last Post: 05-08-2008, 03:42 AM
  5. turn signal problem
    By customcracka in forum Sportbikes & Sport-tourers
    Replies: 4
    Last Post: 12-08-2005, 01:34 AM