Spitting and sputtering 2007 Suzuki Boulevard C50
  • Login:

Welcome to the Motorcycle Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Results 1 to 7 of 7
  1. #1
    Newbie
    Posts
    2

    Unhappy Spitting and sputtering 2007 Suzuki Boulevard C50

    Hello, I just bought a 2007 Suzuki boulevard c50 from someone who kept it in a garage and did not ride it for 3 years. Right after I got it, it started to spit and sputter. I changed the oil, radiator fluid, had the fuel injectors cleaned, replaced the fuel pump, cleaned the spark plugs, etc. We have tried everything it seems, and the bike is still sputtering, especially at low speeds. I’m wondering if maybe it’s an electrical issue? This is my first bike (aside from a Honda Rebel I rode for two weeks). Please help!!!

    edit: I can’t get it to idle at the start.
    Last edited by Lemon814; 08-02-2018 at 10:19 PM.

  2. Remove Advertisements
    MotorcycleForums.net
    Advertisements

  3. #2
    M-J Lifetime Achievement Award
    My Bike(s)
    Yamaha MT09
    Location
    Perth WA
    Posts
    6,709
    I would suspect the fuel system is still clogged somewhere. Best bet would be some good quality fuel system cleaner through and leave overnight. Also since the bike sat for a few years I would be cleaning the fuel tank out and maybe even swapping the fuel lines out too. Check the fuel tank venting also...easy to do just pop the cap when it starts to hesitate.

    Another possible problem may be the battery is not sufficienty charged, the cables are not clean or tight, (a visual check is not sufficient) or the charging system is not working properly...you should see 12.5 across the battery at rest and up to 13.5 to 14 vdc with motor running at around 5k rpm. The cranking voltage mustn't drop below 10vdc or the battery is toast.

    Finally check the coil packs if these are fitted or the coils, cables and caps....not sure what you should get but one may be dropping out....maybe see if you can borrow some?? An alternative would be the check the spak plugsagainnst the cylinder, (ground) to make sure you are getting a decent spark...fat and blue...anything less is suspect


    Good luck
    Smoke me a kipper I'll be home in time for breakfast

  4. #3
    Super Moderator

    My Bike(s)
    Can-AM Spyder
    Location
    Ocala, FL
    Posts
    12,051
    That pretty much covers it.

    If you haven't already, draining the old fuel out of the tank and replacing an external fuel filter (if it has one) would definitely be in order.

    What about modifications to the pipes or air intake ?

    If you are testing with the air filter off, don't do that.

    Having the idle speed set too low can cause problems too.
    Don't believe everything that you think.

  5. Remove Advertisements
    MotorcycleForums.net
    Advertisements

  6. #4
    Newbie
    Posts
    2
    Thank you! I have tried cleaning the fuel tank. We drained all the ordnance fuel out when we got it. We’ll try your other suggestions. Thanks again!

  7. #5
    Super Moderator

    My Bike(s)
    Can-AM Spyder
    Location
    Ocala, FL
    Posts
    12,051
    Quote Originally Posted by Lemon814 View Post
    Thank you! I have tried cleaning the fuel tank. We drained all the ordnance fuel out when we got it. We’ll try your other suggestions. Thanks again!
    What about this stuff ??


    Quote Originally Posted by Easy Rider View Post

    What about modifications to the pipes or air intake ?

    If you are testing with the air filter off, don't do that.

    Having the idle speed set too low can cause problems too.
    Don't believe everything that you think.

  8. #6
    Fifth gear streak
    My Bike(s)
    Suzuki Boulevard M50 2008 Yellow and Black named the Bumble Bee
    Location
    St. Joseph, IL
    Posts
    1,347

    Sputtering C50-

    Quote Originally Posted by Lemon814 View Post
    Hello, I just bought a 2007 Suzuki boulevard c50 from someone who kept it in a garage and did not ride it for 3 years. Right after I got it, it started to spit and sputter. I changed the oil, radiator fluid, had the fuel injectors cleaned, replaced the fuel pump, cleaned the spark plugs, etc. We have tried everything it seems, and the bike is still sputtering, especially at low speeds. Iím wondering if maybe itís an electrical issue? This is my first bike (aside from a Honda Rebel I rode for two weeks). Please help!!!

    edit: I canít get it to idle at the start.
    Did you change the fuel injectors?

    And the fuel of course and the tank was drained and any filter in the tank was changed?
    Any fuel filter in the line?

    Also, air filter? May even be mouse nests in the exhaust or intake.
    CooleyM50

    Riding Bumble Bee the fearless 2008 Yellow, black and gray M50.

    Designer of the M50 Chin Spoiler and 2" Riser Block.
    Manufacture of the M50 1" Riser Block, 2" Smooth and Fluted Riser Block, Chin Spoiler, DK's Rear Filler Plate and soon coming UHL Plate and Front Brake MC CAP.

  9. #7
    Newbie
    My Bike(s)
    2005 C50T
    Posts
    10

    Use the KISS method

    Start with the stuff that's easy to get to unlike the coils and the fuel injectors.

    People tend to have you try the last thing they tried that worked i.e. coils and injectors. In my experience bad coils will cause loss of power once the
    engine is running rather than sputtering. Running fuel and air starvation will both cause sputtering and are easy to check.


    Quote Originally Posted by CooleyM50 View Post
    Did you change the fuel injectors?

    And the fuel of course and the tank was drained and any filter in the tank was changed?
    Any fuel filter in the line?

    Also, air filter? May even be mouse nests in the exhaust or intake.


Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. 1980 Suzuki GN400 sputtering and dying under load
    By sobe6545 in forum Mechanics Corner
    Replies: 26
    Last Post: 02-04-2014, 08:56 PM
  2. S 50 exhaust spitting
    By rhollandphoto in forum The Boulevard
    Replies: 17
    Last Post: 03-25-2011, 04:02 PM
  3. Black smoke and spitting?
    By Dogpound in forum Marauder M50 Secret Hideaway
    Replies: 8
    Last Post: 04-01-2006, 03:48 PM
  4. 98 RMX 250 spitting oil-help
    By JPBabyRange47 in forum Mechanics Corner
    Replies: 2
    Last Post: 10-23-2004, 10:49 AM
  5. backfiring and sputtering
    By steelerfan in forum Dirt Bikes & ATV's
    Replies: 3
    Last Post: 01-26-2004, 03:45 PM

Search tags for this page

04 suzuki c90 boulevard spitting and sputtering and loss of power

Click on a term to search for related topics.