Help with my high idle!
Welcome guest, is this your first visit? Create Account now to join.

Welcome to the Motorcycle Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Results 1 to 5 of 5
  1. #1
    Newbie
    My Bike(s)
    Yamaha 650 V star classic
    Posts
    2

    Unhappy Help with my high idle!

    Just bought a new 2013 V Star 650 Classic. Drove it from the dealership and all was fine. Took it on the road a few hours later and to my dismay the idle speed is way to high and remains high at all times between gears or in neutral. Started the bike and problem remains. ....

    Appreciate your help!

  2. Remove Advertisements
    MotorcycleForums.net
    Advertisements
     

  3. #2
    M-J Lifetime Achievement Award
    My Bike(s)
    Yamaha MT09
    Location
    Perth WA
    Posts
    6,714
    In Au used vehicles...including bikes... have a statuary three months warranty this would be covered... and if USA is the same then take it back.
    Smoke me a kipper I'll be home in time for breakfast

  4. #3
    Super Moderator

    My Bike(s)
    Can-AM Spyder
    Location
    Ocala, FL
    Posts
    12,066
    Quote Originally Posted by jehan View Post
    Just bought a new 2013 V Star 650 Classic.
    Welcome to the forum.

    First consult your owners manual to see if there is an idle adjustment and make sure the throttle has spring to it and is returning all the way back.

    If those two things don't solve the problem, take it back to the dealer.
    If it really is a "new" '13 model, it has the original manufacturers warranty.
    If you are at all uneasy about riding it, call them to come and get it.

    If used, they still should make it right.
    Don't believe everything that you think.

  5. Remove Advertisements
    MotorcycleForums.net
    Advertisements
     

  6. #4
    Newbie
    My Bike(s)
    Yamaha 650 V star classic
    Posts
    2
    The problem did not reoccur. Mentionned it to the dealer who was quite concerned by the event ,and readjusted the idle speed slightly. Took the bike for a 80km spin to warm it up and the the carbs responded normally. Upon releasing the throttle, the speed came down slowly and upon either engaging the clutch or putting the bike in neutral the idle speed came down to normal....

    Much appreciate your help and comments..

    Jehan

  7. #5
    M-J Lifetime Achievement Award
    My Bike(s)
    Yamaha MT09
    Location
    Perth WA
    Posts
    6,714
    Its refreshing to get genuinely good service these days.
    Smoke me a kipper I'll be home in time for breakfast


 

Sponsored Links

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 5
    Last Post: 11-16-2007, 08:58 AM
  2. High Idle
    By jjg544 in forum Mechanics Corner
    Replies: 5
    Last Post: 08-31-2006, 01:52 AM
  3. high idle?
    By cap2016 in forum Mechanics Corner
    Replies: 3
    Last Post: 08-05-2006, 01:18 PM
  4. High Idle
    By Rumble Bee in forum Sportbikes & Sport-tourers
    Replies: 4
    Last Post: 07-06-2005, 10:21 PM
  5. Too high an idle?
    By Y2Kalonn in forum Sportbikes & Sport-tourers
    Replies: 3
    Last Post: 06-11-2005, 01:32 PM

Search tags for this page

vstar 650 idles high when warm

Click on a term to search for related topics.