Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought this bike used and after running for a while, I get the overtemp light to come on dim then after a while of sitting it comes on bright sometimes. I have cleaned out the cooling system, changed the temp sensor, changed the thermostat changed the fan temp sensor and still the light will come on dim and sometimes bright. I keep on seeing topics of a service bulletin of a ground added to the instrument cluster to fix the problem. I can't find this service bulletin on line. Does anyone have a copy of this?
 

·
Super Moderator
Joined
·
12,659 Posts
Have you tried a Triumph dealer ??

If the problem really is just with the LIGHT and not the actual cooling.......you have already wasted a LOT of time and effort and money chasing a ghost.....maybe.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I know, that's why I like to know if the service bulletin would fix the problem like everyone says. I need to know what wire to connect the added ground to.
 

·
Registered
Joined
·
6,861 Posts
If the overflow bottle is filling up and coolant is running out of the drain it is overheating...but as you havent said there have been any of the obvious overheating syptoms then it must be the light issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I am going to try and get the service bulletin attached to this. I finally found the service bulletin from Triumph on the temp light. I did this service bulletin to my bike and it looks like it fixed the problem. If your bike has not been done, I would fix it. You will save a lot of aggravation.
 

Attachments

1 - 5 of 5 Posts
Top