Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello guys,

Im new to the community and I really need some assistance. Few days ago I started riding my bike more then usual as I'm in process of buying a new vehicle. I noticed my M50 leaving spots in its usual place of parking. Today I was going on a 100 mile ride warm and cold temperature and hills as well. Well on the left hand side where the engine and exhaust is put together there is a leak coming from the small bolts holding the valve cover on the engine. I have attached pictures. Please help me because I need to know what I need to fix!! I just bought the bike so I haven't done an oil change it'll be due here in the next 1k miles. It's currently has 11k on the clock.

Thank you so much!
 

Attachments

·
Super Moderator
Joined
·
12,338 Posts
Can't tell from the pictures where the oil is really coming from but it is probably NOT a valve cover.
Let's hope that it is a loose or defective side cover gasket because that is an easy and cheap fix.
I strongly suggest that you get a Suzuki or good independent shop to take a look at this.......because doing the wrong thing here could have dire consequences.

You did check the oil level, right ?? It also could be just having WAY too much oil in it, as a result of checking the level wrong.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes, since I was riding late last night I couldn't check for shops. Now that bike is cooled down in going to check oil level today. From the looks of it it's coming directly from the small bolts that hold the side panel to the engine. I'm guessing the gasket
 

·
Registered
Joined
·
357 Posts
Yes, since I was riding late last night I couldn't check for shops. Now that bike is cooled down in going to check oil level today. From the looks of it it's coming directly from the small bolts that hold the side panel to the engine. I'm guessing the gasket
Just in case you don't know, you need to warm up the bike for about 5 min, take a quick ride around the block or something, then let sit for a couple minutes, then make sure the bike is upright and level when checking the oil. If you check the oil while on the kickstand, it will read much lower than the actual level. You need to have a partner hold the bike up or put a block under the kickstand or something to get an accurate reading.
 

·
Super Moderator
Joined
·
12,338 Posts
Yes, since I was riding late last night I couldn't check for shops. Now that bike is cooled down in going to check oil level today. From the looks of it it's coming directly from the small bolts that hold the side panel to the engine. I'm guessing the gasket
Well then I would suggest that you get the proper size socket and snug them all down.
Notice that I did not say TIGHT.
Then take it to a shop to have the proper torque applied.
That might fix the problem. If not, a new gasket should definitely fix it.
I guess there is an outside chance the cover itself it damaged but even that wouldn't be too expensive to fix.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks guys! Actually found the solution and problem on youtube. It's the clutch cover gasket. Easy fix and part is 11.99 online!
 
1 - 6 of 6 Posts
Top