Motorcycle Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello! I just bought this bike and have very little motorcycle experience. Ive ridden it to work and back all week(~2 miles round trip, max speed 50). My friend took it out for a more extensive ride and found he was not able to go any faster than ~80, even downhill. Does anyone have any ideas as to what could be causing this?
 

·
Super Moderator
Joined
·
13,463 Posts
There is a rev limiter......but that shouldn't cause it unless he didn't realize how many gears it has.

The European models sold in many countries also have a top speed limiter.

Did he mention what the engine RPM was at 80 ??
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
There is a rev limiter......but that shouldn't cause it unless he didn't realize how many gears it has.

The European models sold in many countries also have a top speed limiter.

Did he mention what the engine RPM was at 80 ??
So that was yesterday, he just called me and told me he took it out again today and same thing only today he was barely chugging at ~55 MPH. Full throttle,6th gear, downhill; Still 55. It shouldn't be a European model, as it was bought from a used dealership in Georgia, USA, but I guess it could be. We are toying with the idea that it is running VERY lean for some reason.
 

·
Registered
Joined
·
7,057 Posts
Its important to describe what is happening...if the bike bogs down then it could be too much fuel which would probably lead to the air intake being blocked/modified or poor spray pattern from injectors. If it breaks up on hard acceleration then I would suspect the fuel delivery specifically the fuel pump filter/s. Low pressure side is replaceable the internal one, if fitted, isnt. but many have success by reverse flushing the pump with fresh fuel. Needless to say this will mean removing the pump if its an internal one.

You may also have a faulty fuel pressure sensor...this will cut the fuel supply too soon and at too low a pressure for the injectors to keep up with a consistant supply.

It may have an electrcal fault...even something as simple as a coil pack connector being loose through to a coil pack breaking down at higher speeds..

Can you find the dealer plug....Suzuki ones are under the tail and consist af a single plug with two wires that have to be jumped to put it into dealer mode to see if its throwing any codes.

I would be tempted to run some fuel system/injector cleaner through and leave it overnight then start looking elsewhere if that doesnt work.....although you may have to use it more than once. Just had a thought....pop the tank cap when it does this....any inrush of air may indicate a tank breather problem...might also want to check the fuel line isnt kinked or otherwise damaged.

Good luck
 

·
Super Moderator
Joined
·
13,463 Posts
I would be tempted to run some fuel system/injector cleaner through and leave it overnight then start looking elsewhere if that doesnt work.....although you may have to use it more than once. Just had a thought....pop the tank cap when it does this....any inrush of air may indicate a tank breather problem...might also want to check the fuel line isnt kinked or otherwise damaged.
THIS.
Also fuel filter maybe.

Any chance that somebody put WAY too much fuel stabilizer in the gas ?
Or any other additive for that matter.

Also maybe some bad gas, clogged muffler or plugged air filter.
 
1 - 8 of 8 Posts
Top