Motorcycle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I need help, so recently when i downshift or let off the throttle my whole bike stutters. To be clear, its not a shaking feel, more of a sputter, but rather violent. At first i thought it might be my sproket or chain, but when i clutch it, the sputtering stops. This doesnt happen when im on the throttle or upshifting. Does anyone know what this problem might be? Or the fix? Thanks
 

·
Super Moderator
Joined
·
13,408 Posts
You need a more experienced rider or mechanic to assess your situation.......with an onsite inspection and ride.

If you are doing this at very high RPMs, at or near redline, stop doing that !! :shock:
(Only partly kidding with that remark.)

It still can be the chain and sprockets but it could be wheel bearings, brakes or transmission too.

I suggest that you not ride it much (or at all) until you get it figured out.
If something breaks suddenly, it might put you in the hospital.
 

·
Registered
Joined
·
7,028 Posts
Is this an fuel injected bike? Have you fitted an aftermarket exhaust and if so sometimes the ecu needs to be re-flashed.

If this has just started then the injectors may need a clean....the fuel pump filters may need cleaning....this is a very strong possibility and a lot of injected machines also have a filter at each injector. I would try some injector cleaner through it....give it some throttle to get the stuff through then leave it over night. If it makes some difference the the filters would be suspect IMO.

One other thing check your fuel tank venting...ditto with all plumbing and if you popped the tank off then check the fuel line routing too.


re-post your findings if non of this helps.

Good luck
 
1 - 3 of 3 Posts
Top