Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Just bought an '06 Boulevard and drove it home 80 miles last night. Stopped for gas and when I shut it down I noticed the CHEC indicator on and the oil can lit up. When I start the bike now the CHEC goes off and the odometer appears, but the red oil can stay on below. Oil was changed about 200 miles ago and still reads at the full line with the bike straight up.

Any suggestions?

Tom
 

·
Registered
Joined
·
23 Posts
Just bought an '06 Boulevard and drove it home 80 miles last night. Stopped for gas and when I shut it down I noticed the CHEC indicator on and the oil can lit up. When I start the bike now the CHEC goes off and the odometer appears, but the red oil can stay on below. Oil was changed about 200 miles ago and still reads at the full line with the bike straight up.

Any suggestions?

Tom
Disregard the banned members pointless comment.

It's likely a sensor for oil level, and pressure depending on model. 80 miles with no oil pressure would ruin the engine.
How many miles are on it?
What size engine is this?
You have an external filter, put your hand on it and you can feel oil pulses through it, and naturally you know you have a capacity of oil that you checked upright, so that was done correctly.

No ticking noises?
If all indications are full oil, oil pressure in the system, it's either someone put the wrong weight oil in it (200 miles ago), or a bad sensor.
 
1 - 3 of 3 Posts
Top