Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I was installing my fender eliminator and LED tailight last night and while hooking it up we blew a fuse. I now have no tach, speedo, tail light, brakes, blinkers... Is that fuse under the seat? If so how so I get that sucker off?

Anyone have a link to a writeup on how to wire the new tail section back up so I don't blow a bunch of fuses with trial and error?
 

·
Registered
Joined
·
10,553 Posts
I don't have that information on hand for the rewiring. Is this a homemade fender eliminator?

If it's a commercial one, you should have wiring instructions.

As for the fuse, check your owner manual, it should have that in there.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
Louis Yes, this is a "homemade" eliminator kit. I bought one of the LED taillights off Ebay that have the blinkers integrated into the taillight area. I just cut the fender and old blinkers off. I didn't get a manual when I bought my bike...

bigE Thanks for the link. It was just what I needed to get it finished :)



Thanks to both of you for the help. Last night after work I spend about 30 minutes on it and all is well again. No more junk hanging off the rear of the bike and all my stuff works again:mrgreen:
 

·
Dastardly villain
Joined
·
1,700 Posts
goodwork on getting it done. Post some pics! I actually found out after I installed my hotbodies undertail that I like the stock tail more than the aftermarket after I cut a bit of the mudguard off the stock.
 
1 - 5 of 5 Posts
Top