Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi Group!

STILL trying to track down my elusive stall/miss/hesitation on the 06 m50. Do any of you have an easy way to remove and replace ignition coils? I took off the tank but it looks like there is NO room for an allen wrench to get them off. I'm thinking I've got to drain the radiator , remove it and go in from the front of the bike. Worst part is I'm not sure it's the coils . I'm just "loading the parts cannon" at this point. (already put $400 worth of injectors in ,to no avail) no codes, no engine light. Just stalling out when warm (after 8/10 miles) and running on one cylinder when under load. ( running along at low revs in a high gear and opening throttle wide quickly, back off OR open it slowly no problem)

anyhow thanks in advance
Joe
 

·
Super Moderator
Joined
·
12,532 Posts
STILL trying to track down my elusive stall/miss/hesitation on the 06 m50.
IF.....this really is just a continuation of another thread that you already created.......
In the future, please keep it all together, so we don't have to cover the same ground all over again.
Thanks.

Based ONLY on this post, sounds like a fuel pressure/flow problem to me.
Fuel filter.
Fuel pump.
Bad tank vent.
 

·
Registered
Joined
·
6,832 Posts
I'm with Er on this I wouldnt be spending money on guesses. A simple test for tank venting is run it till it stalls then pop the tank cap....if it runs OK afterwards then you found the fault with no cash spent.

A few dollars will get you some fuel additive to clean out the fuel filters/injectors etc. The Fuel filters are usually non replaceable but many have flushed the pump using raw gas with good results. Even if this result doesnt last you know you found the fault....again with little to zero cash spent.


Good luck
 
1 - 3 of 3 Posts
Top