Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey all !
This my first post. I have a 2008 M50. Got new pipes MOTORCYCLE-EXHAUST.COM - BEST PRICES FREE SHIPPING: ROADHOUSE OUTLAW BLACK COMPLETE EXHAUST VOLUSIA800 / INTRUDER800 / BOULEVARD C50 / BOULEVARD M50 (thats the exact pipes i have. These pipes back fire when ever i let the throttle go. So i bought a power commander III EX. Can some one tell me what is the closest map i can download for these exhaust because the map is not avalable for this exact exhaust, so i know it has to be the closet one to it.

question 2- once downloaded and the pciii installed what do i do next to prevent the back fire? i dont care about getting extra hp or anything i just dont want back fire. Does it fix it self once i turn it on or what do i have to do. I am getting stationed in turkey soon and i will be stranded there with no help so please advice!!!! thanks guys

Shine side up and rubber side down
Ely
 

·
Registered
Joined
·
168 Posts
I can't be 100% sure, but it sounds like to me the back firing you are getting is a natural result of replacing the stock exhaust. This can be caused by the PAIR Valve system that comes stock on the motor. Read more about it here:

Pair Valve

As far as the map, I can't much help you with that, but if you do a search function, you may be able to find something.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
wow thanks !!

i wonder why i bought the power commader now? any way how to i simply disable it? i dont care about removing it i just dont want the backfiring. Can i just open it up and un plug something ? thanks
 

·
Registered
Joined
·
926 Posts
i wonder why i bought the power commader now? any way how to i simply disable it? i dont care about removing it i just dont want the backfiring. Can i just open it up and un plug something ? thanks
Hey nice pipes! Those look wicked--any pics on your bike? I have an old Jardine 2-1 and had a lot of backfiring too. I had de-paired prior to installing the pipes (stock intake btw) and still had the backfiring. Once I got a PC-V installed and downloaded a similar map (major PITA but once I got through to a customer svc rep it was cool...operator error, lol...guess I'm not 10% smarter than THAT equipment) the backfiring went away. Hope you get somewhere with your issue!
 
1 - 4 of 4 Posts
Top