Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 883 Sportster Low with 400 miles on it. I moved to california and deployed for a year. now its time to ride, but the battery was dead as a door nail. I changed out the battery and it turned over just fine... but didnt start. shot a squirt of gas in the carb and its puttered... sorry, I didnt tell you its EFI. also noticed that the fule pump wasnt running. so, I cracked into the tank, pulled out the fuel pump & filter cluster and changed out the fuel pump. the tank had a bunch of rust all over the insides. so, with metal rescue (home Depot) cleaned right up, installed the new fuel pump and filter cluster and filled the tank with new fuel..... still nothing. the new fuel pump doesnt make a sound.
the key on the speedo goes on and off like normal.
when I flip the switch from on to off, I hear something resets betwin the jugs..
your thoughts?
 

·
Registered
Joined
·
1,398 Posts
gunked up injectors would be my guess. or gunked up fuel lines.

and how did you squirt gas in the carbs on an efi bike?
 

·
Registered
Joined
·
2,627 Posts
Oh man you should have parked her with a full tank and stabil added, no doubt the whole fuel system is plugged up with rust.
Sorry I can't help, I'm a carb guy and not savvy on EFI but I'm sure that's the problem.
Might be time for a trip to the dealer but I'd check for a fuse blown and if you can get thje pump working get a bunch of fuel injector cleaner in there and maybe you'll get lucky.
 
1 - 6 of 6 Posts
Top