Motorcycle Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just bought my new Suzuki Gixxer 155 four days back. I have hardly traveled 100 kms in it. I also maintain my speed well within 40-50 because the bike has not been serviced yet. But whenever I take my bike out for a small ride even, I noticed the engine getting heated up. When I tried to go near the engine, it somehow smelled like something is burning. But after keeping for 15-20 minutes, it again gets back to normal. I am not able to understand the reason behind this. Is my bike defective? Or is it because it is air cooled? Or is it because the first maintenance is not done yet?
 

·
Premium Member
Joined
·
14,185 Posts
When a new bike comes out of the factory, it has never run. During the initial days, it's normal that it "smells funny" when it gets up to temperature. This is excess paint burining off, oil that was left over from the CNC machines when the parts were made, etc.

Bottom line - it's normal. Your dealer should have mentioned this to you.
 

·
Registered
Joined
·
7,050 Posts
You will also find once its run in and you travel at higher speeds the cooling effect of air through the radiator will reduce some of this...until you're stuck in traffic that is :mrgreen:

Good luck and ride safe.
 

·
Registered
Joined
·
7,050 Posts
Just saw Gixxer and thought 250 and above...didnt know they did a tiddler 155 and indeed air cooled...same thing applies though but without the radiator bit.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top