Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Greetings !
I just picked up a 2013 Suzuki GW250 as a first bike for my girlfriend. Seems like a good all around fit for size.
It needs a shift lever (pedal) and I am having a hard time finding any reference to it at all (I have the part number). There seems to be nothing available. (But lots of similar on gsx and vstrom).
Looking for a forum here to discuss and it not finding a category for that bike.... no parts, no forums.... did I buy some oddball limited thing that no one supports?!

Thanks !

etro
 

·
Super Moderator
Joined
·
12,831 Posts
At only 7 years old, parts should still be available from dealers.
I suggest that you need to contact a Suzuki dealer.

If not possible to take the bike to them, than take some pictures and note the factory VIN.
Maybe it isn't the model bike that you THINK it is.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
At only 7 years old, parts should still be available from dealers.
I suggest that you need to contact a Suzuki dealer.

If not possible to take the bike to them, than take some pictures and note the factory VIN.
Maybe it isn't the model bike that you THINK it is.
I would agree! Just talked to a dealer and they say the part number "shows and error" when trying to find it in their system. They supplied the part number I didnt give it.
I can try to verify the vin, it has the stickers and matches original pictures, i'm assuming its the right bike.
 

·
Super Moderator
Joined
·
12,831 Posts
I would agree! Just talked to a dealer and they say the part number "shows and error" when trying to find it in their system. They supplied the part number I didnt give it.
Then it is a problem that THEY should be responsible for fixing.
They have people they can contact for problems like that.........if they just WILL.
 

·
Registered
Joined
·
6,917 Posts
Go to a wreckers...likely you will find a gear lever that will fit....maybe even from the same machine
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I was able to find a mostly workable part.
The angle is wrong, so I had to adjust the spline side a bit and shorten the connecting rod, but the action is smooth so it worked out.

Not technically for the GW250 though.


Still a bit thrown by the lack of available parts for a 2013, I guess I'm use to my beemers, you can get everything.
 

·
Super Moderator
Joined
·
12,831 Posts
Still a bit thrown by the lack of available parts for a 2013, I guess I'm use to my beemers, you can get everything.
You are not getting it.
The situation you described is NOT necessarily a "lack of parts" but an error in their parts inventory computer.
This most likely could be rooted out and fixed.....IF you applied enough pressure in the right place.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
but an error in their parts inventory computer
For sure, and I might still hit them up. I was more commenting on even aftermarket. There seems to be every oddball thing out there, but nearly nothing for this bike.
 
1 - 9 of 9 Posts
Top