Motorcycle Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Can anyone please tell me if this is a problem? It doesn't look right. Hopefully I'm just being paranoid.

Bike.jpg

Also, my bike (Victory Vegas 8 Ball) is having weird RPM issues and "choking," cruising, on 4th gear at 2500 Rpms. and between 40-55mph.

Cheers
Matt
 

·
Super Moderator
Joined
·
12,836 Posts
I don't understand.
What exactly in that picture do you think might be a problem ?

And at what speed does it choke at 2500 RPM ?

My first guess is that you are lugging the engine; that is trying to make it "pull" at too low a speed for that gear.
2500 isn't much above idle. The only time my engine is turning that slow is in 1st gear just coming off the line.......and most of the time not even then.

:mrgreen:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Reply

Thank you so much for the quick response!!! Very helpful and clears up the lugging feeling.

The picture however is of what I think is a broken peice or missing bolt??? Is there supposed to be an open screw hole there with what looks like a sheared off peice of steel? Maybe it's a mount for an intake or something? IDK anything about bikes so to me it looks wrong?

Cheers matt

I don't understand.
What exactly in that picture do you think might be a problem ?

And at what speed does it choke at 2500 RPM ?

My first guess is that you are lugging the engine; that is trying to make it "pull" at too low a speed for that gear.
2500 isn't much above idle. The only time my engine is turning that slow is in 1st gear just coming off the line.......and most of the time not even then.

:mrgreen:
 

·
Registered
Joined
·
1,359 Posts
It's hard to tell if you're not intimately familiar with Victory bikes. I'd run it by a dealer and see what they say.
 

·
Registered
Joined
·
1,628 Posts
Nothing is missing, the engine is used in all of Victory motorcycles and that is a mounting area for another model. Your fine.
 
1 - 8 of 8 Posts
Top