Motorcycle Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi all, I just got my motorcycle out of the garage, fueled it up, and tried to get it running. The problem is, it wont run! I can start it, and it will idle, around 1k, but the moment I hit the gas it dies. A couple times I got it revving by holding the gas while I started it, but the moment I let it down to 2k RPM it dies. I hope someone has an idea because I am kinda a newb. BTW it is a '84 Honda Magna.
 

·
Registered
Joined
·
578 Posts
I had that problem with my 84 magna. The carbs get fouled pretty easy. Especially if there is any rust in the tank. Try running some cleaner through it. If that didn't work, might be time to clean them out. Not fun.



Joe
 

·
Registered
Joined
·
5,202 Posts
Fouled jets in the carbs sound likely. Has the bike been sitting for more than 4-6 weeks? If so, the ethanol-gas mix they sell these days will degrade and turn into varnish very quickly and gum things up. Dump in some SeaFoam, Berryman's, or other brand name carb cleaner. If the bank is going to sit for a while (like next winter) dump some fuel stabilizer in the tank, then run it long enough to get the treated gas down into the carbs. Leave the petcock on so as the gas in the carbs evaporates out the vents it gets replaced with more gas instead of leaving a gunky coating on the bowls.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top