Motorcycle Forum banner

1 - 6 of 6 Posts

Registered
Joined
4 Posts
Discussion Starter #1
Hi my names Luke

Looking at doing my DAS next year so getting my DR125SM back in working order after being stood for 7 years.

Tried starting my bike with the help of a battery charger attached it done the usual FI prime for a few seconds with the FI light on and as soon as its primed the light goes off.

Now the only thing that tells me the bike has electric running through it is the primer priming but never switching off until the ignition is off.

Just when you want to be more mechanically minded these things happen I suppose we learn more from mistakes though. 馃槄
 

Super Moderator
Joined
12,761 Posts
Welcome.
What is a DAS ?

The FI light stands for "fault indicator".
If it goes off, that probably isn't significant.

You may have more than one problem.
Need to start with a new battery, fully charged.
Then you need a multi-meter to trace voltages......if it doesn't crank with a new battery.
 

Registered
Joined
4 Posts
Discussion Starter #3
Hi easy rider

The fi light use to come on whilst you can hear the primer then when it stops both but now no fi light but primer on constant until ignition is switched off.

Will have to get a multi-meter and have a play with it.

Forgot to mention it killed a 3 amp switch on the battery charge but checked the 20 amp fuse in bike and that still good.

Do think the starter relay could affect the primer side off the electronics or would you say thats more controll unit?

Sent from my SM-N976B using Tapatalk
 

Registered
Joined
6,885 Posts
The primer should switch off once a certain pressure is reached....I would suggest the sensor that measures that is either disconnected or faulty. Either way a wiring diagram will be needed to locate that sensor.

Good luck
 

Registered
Joined
4 Posts
Discussion Starter #5
Hi guys just updating the progress with my bike.

After an hour or so checking continuity between wires as there was a little corrosion and checking the starter motor relay and also checking the battery (1 volt from the 12v battery)

So I got the jump leads hooked it up to my car (with the car ignition off) I turned my bike ignition on it primed it for few seconds and then switched off which it was supposed to do not constantly prime like before.

One blip of the starter motor the bike cranked and started first time and run for a few mins :).

Next job drain fuel anyone know where I can legally dispose of it as I'm not sure if the local recycling centre allows stagnant fuel.


Sorry for the late reply bike is kept in a different location then where I live and family life with a one year old doesn't give me much time.

Will send some pictures below ( wish I cleaned and covered it before I stored it)



Sent from my SM-N976B using Tapatalk
 

Registered
Joined
7 Posts
Hi my names Luke

Looking at doing my DAS next year so getting my DR125SM back in working order after being stood for 7 years.

Tried starting my bike with the help of a battery charger attached it done the usual FI prime for a few seconds with the FI light on and as soon as its primed the light goes off.

Now the only thing that tells me the bike has electric running through it is the primer priming but never switching off until the ignition is off.

Just when you want to be more mechanically minded these things happen I suppose we learn more from mistakes though. 馃槄
Clutch switch possibly or feul pump pressure or ... clutch switch tbh or kill switch on kickstand or by hand . Check it out
 
1 - 6 of 6 Posts
Top