Motorcycle Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2006 S50 - when the front forks are turned left the right front turn signal works. When the forks are turned right the right front turn signal will NOT blink. Any ideas?
 

·
Still crazy after all these years
Joined
·
14,182 Posts
And if you think that replacing the air filter is going to fix an electrical problem, don't forget to replace your blinker fluid - it will add 25 horsepower to your engine performance. As long as you remember to lube the exhaust pipes and wash out the gas tank with distilled water before each filling. Sheesh. :roll:
 

·
Registered
Joined
·
95 Posts
You right that tex off the wall, shynot happens. What I should have said was that the pinch point is probably around the neck and don't discount looking inside the headlight housing. Mine was '02 Volusia 800 with carb.

Sent from my Z797C using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
:welcomes: to the forums from Arkansas.:cool: One of the wires going to the right signal is open and makes contact when you move the forks.:)
I have traced the problem to where the wires go into the "console" unit (where the indicator lights are). When I push on these wires the blinker will work. To open the back of this console unit looks like the entire headlight assembly has to be removed. I attached a picture where wires are entering unit. I used a pointer to show area. Does the headlight assembly have to be removed as it appears? Does anyone have instructions on how to remove it? Or a place I can find instructions?
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #8
I have traced the problem to where the wires go into the "console" unit (where the indicator lights are). When I push on these wires the blinker will work. To open the back of this console unit looks like the entire headlight assembly has to be removed. I attached a picture where wires are entering unit. I used a pointer to show area. Does the headlight assembly have to be removed as it appears? Does anyone have instructions on how to remove it? Or a place I can find instructions?
I found the way to get the light assembly off. Removed back of console unit. Looks like the loose connection may be in speedometer unit now. Slowly trying to get to the real problem. Now have to discover how to remove speedo cover to get to wires in the back of it.
 
1 - 8 of 8 Posts
Top