Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I live in Gainesville Florida and I own a 2005 C90. In late Octobre the bike started to run on one cylinder, lose power and backfire so I called the shop where I bought it and was told that they didn't work on bikes that old (!!!). I stop riding and winterized it until I found a solution. Does anybody knows a good mechanic in or around Gainesville that could look at it and fix it? Thanks for any help!
 

Attachments

·
Registered
Joined
·
11 Posts
I live in Gainesville Florida and I own a 2005 C90. In late Octobre the bike started to run on one cylinder, lose power and backfire so I called the shop where I bought it and was told that they didn't work on bikes that old (!!!). I stop riding and winterized it until I found a solution. Does anybody knows a good mechanic in or around Gainesville that could look at it and fix it? Thanks for any help!
 

·
Registered
Joined
·
11 Posts
Sounds like the signal generator, located and connected to the stator....go to lcriders.com and post your issue...those folks can talk you through the repair. Pa
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Sounds like the signal generator, located and connected to the stator....go to lcriders.com and post your issue...those folks can talk you through the repair. Pa
Thank you for the response. Some other mechanic I went to told me that it was a valves problem..... Could it be??
 
1 - 5 of 5 Posts
Top