Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So, I bought a 2020 Yamaha R3 brand spankin new at the end of April of 2021, 30 days ago. No mileage, straight from factory. Have not driven it in rain, for those curious. Probably driven it maybe 20 or 30 times since then, had a minor slow drop while not moving and managed to cushion the bike, this drop bent my gear shift lever in a bit but doesn't bother the functionality of the shift lever and had no other issues. Then about a week after that went to a friend's and somehow a little bit of this sticky drink got spewed on the back of my bike, not much at all though but it did make its way down into the back seat a little, like a trickle line, but it only seemed to be on the inner bike fairings and on nothing important, no wires or ports or anything. But, still worth mentioning. Then maybe a day or two after that I started having an issue with my dash indicator light. Oddly enough, my dash indicator light for my left hand signal flashes once, when I shift from 1st to 2nd and from only those gears. Just the dash indicator light comes on, not the actual turn signals. I would appreciate any help or ideas about this fix, as the bike is not originally designed to do this when shifting, did not do this before, and it makes me worry of a greater problem if left unfixed. Couldn't find anything at all online about this weird issue. Thank you!
 

·
Super Moderator
Joined
·
13,153 Posts
First, look closely at the light that flashes to be sure that it is not the neutral indicator light.
It is pretty normal for that to flash when you go from 1 to 2 and pass neutral.
Does the neutral indicator light work like it should ?

If that is not what is happening, I think you should make a warranty visit to the dealership.
Neither of the "incidents" you mentioned should cause anything like that.
If there IS a fault present, it almost has to be in the speedo/dash assembly.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
First, look closely at the light that flashes to be sure that it is not the neutral indicator light.
It is pretty normal for that to flash when you go from 1 to 2 and pass neutral.
Does the neutral indicator light work like it should ?

If that is not what is happening, I think you should make a warranty visit to the dealership.
Neither of the "incidents" you mentioned should cause anything like that.
If there IS a fault present, it almost has to be in the speedo/dash assembly.
Yes, it's the left turn signal indicator light, not the neutral indicator light. The neutral light works perfectly. Also, thank you for the feedback!
 
1 - 3 of 3 Posts
Top